Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > C

curses(5)

CURSES
HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

curses: curses.h — definitions for screen handling and optimization functions

SYNOPSIS

#include <curses.h>

DESCRIPTION

Objects

The <curses.h> header provides a declaration for COLOR_PAIRS, COLORS, COLS, curscr, LINES and stdscr.

Constants

The following constants are defined:

EOF

Function return value for end-of-file

ERR

Function return value for failure

FALSE

Boolean false value

OK

Function return value for success

TRUE

Boolean true value

WEOF

Wide-character function return value for end-of-file, as defined in <wchar.h>.

Data Types

The following data types are defined through typedef:

attr_t

An OR-ed set of attributes

bool

Boolean data type

chtype

A character, attributes and a colour-pair

SCREEN

An opaque terminal representation

wchar_t

As described in <stddef.h>

wint_t

As described in <wchar.h>

cchar_t

References a string of wide characters

WINDOW

An opaque window representation

These data types are described in more detail in Data Types in curses_intro(3X).

The inclusion of <curses.h> may make visible all symbols from the headers <stdio.h>, <term.h>, <termios.h> and <wchar.h>.

Attribute Bits

The following symbolic constants are used to manipulate objects of type attr_t:

WA_ALTCHARSETAlternate character set
WA_BLINKBlinking
WA_BOLDExtra bright or bold
WA_DIMHalf bright
WA_HORIZONTALHorizontal highlight
WA_INVISInvisible
WA_LEFTLeft highlight
WA_LOWLow highlight
WA_PROTECTProtected
WA_REVERSEReverse video
WA_RIGHTRight highlight
WA_STANDOUTBest highlighting mode of the terminal
WA_TOPTop highlight
WA_UNDERLINEUnderlining
WA_VERTICALVertical highlight

These attribute flags shall be distinct.

The following symbolic constants are used to manipulate attribute bits in objects of type chtype:

A_ALTCHARSETAlternate character set
A_BLINKBlinking
A_BOLDExtra bright or bold
A_DIMHalf bright
A_INVISInvisible
A_PROTECTProtected
A_REVERSEReverse video
A_STANDOUTBest highlighting mode of the terminal
A_UNDERLINEUnderlining

These attribute flags need not be distinct except when _XOPEN_CURSES is defined and the application sets _XOPEN_SOURCE_EXTENDED to 1.

The following symbolic constants can be used as bit-masks to extract the components of a chtype:

A_ATTRIBUTESBit-mask to extract attributes
A_CHARTEXTBit-mask to extract a character
A_COLORBit-mask to extract colour-pair information

The following symbolic constants can be used as bit-masks to extract the components of a chtype:

A_ATTRIBUTESBit-mask to extract attributes
A_CHARTEXTBit-mask to extract a character
A_COLORBit-mask to extract colour-pair information

Line-Drawing Constants

The <curses.h> header defines the symbolic constants shown in the leftmost two columns of the following table for use in drawing lines. The symbolic constants that begin with ACS_ are char constants. The symbolic constants that begin with WACS_ are cchar_t constants for use with the wide-character interfaces that take a pointer to a cchar_t.

In the POSIX locale, the characters shown in the POSIX Locale Default column are used when the terminal database does not specify a value using the acsc capability as described in Line Graphics in terminfo(4).

  POSIX Locale 
char Constantcchar_t ConstantDefaultGlyph Description
ACS_ULCORNERWACS_ULCORNER+upper left-hand corner
ACS_LLCORNERWACS_LLCORNER+lower left-hand corner
ACS_URCORNERWACS_URCORNER+upper right-hand corner
ACS_LRCORNERWACS_LRCORNER+lower right-hand corner
ACS_RTEEWACS_RTEE+right tee
ACS_LTEEWACS_LTEE+left tee
ACS_BTEEWACS_BTEE+bottom tee
ACS_TTEEWACS_TTEE+top tee
ACS_HLINEWACS_HLINE-horizontal line
ACS_VLINEWACS_VLINE|vertical line
ACS_PLUSWACS_PLUS+plus
ACS_S1WACS_S1-scan line 1
ACS_S9WACS_S9_scan line 9
ACS_DIAMONDWACS_DIAMOND+diamond
ACS_CKBOARDWACS_CKBOARD:checker board (stipple)
ACS_DEGREEWACS_DEGREE'degree symbol
ACS_PLMINUSWACS_PLMINUS#plus/minus
ACS_BULLETWACS_BULLETobullet
ACS_LARROWWACS_LARROW<arrow pointing left
ACS_RARROWWACS_RARROW>arrow pointing right
ACS_DARROWWACS_DARROWvarrow pointing down
ACS_UARROWWACS_UARROW^arrow pointing up
ACS_BOARDWACS_BOARD#board of squares
ACS_LANTERNWACS_LANTERN#lantern symbol
ACS_BLOCKWACS_BLOCK#solid square block

Colour-related Macros

The following colour-related macros are defined:

COLOR_BLACK COLOR_BLUE COLOR_GREEN COLOR_CYAN COLOR_RED COLOR_MAGENTA COLOR_YELLOW COLOR_WHITE

Coordinate-related Macros

The following coordinate-related macros are defined:

void getbegyx(WINDOW *win, int y, int x); void getmaxyx(WINDOW *win, int y, int x); void getparyx(WINDOW *win, int y, int x); void getyx(WINDOW *win, int y, int x);

Key Codes

The following symbolic constants representing function key values are defined:

Key CodeDescription
KEY_CODE_YESUsed to indicate that a wchar_t variable contains a key code
KEY_BREAKBreak key
KEY_DOWNDown arrow key
KEY_UPUp arrow key
KEY_LEFTLeft arrow key
KEY_RIGHTRight arrow key
KEY_HOMEHome key
KEY_BACKSPACEBackspace
KEY_F0Function keys; space for 64 keys is reserved
KEY_F(n)For 0≤n≤63
KEY_DLDelete line
KEY_ILInsert line
KEY_DCDelete character
KEY_ICInsert char or enter insert mode
KEY_EICExit insert char mode
KEY_CLEARClear screen
KEY_EOSClear to end of screen
KEY_EOLClear to end of line
KEY_SFScroll 1 line forward
KEY_SRScroll 1 line backward (reverse)
KEY_NPAGENext page
KEY_PPAGEPrevious page
KEY_STABSet tab
KEY_CTABClear tab
KEY_CATABClear all tabs
KEY_ENTEREnter or send
KEY_SRESETSoft (partial) reset
KEY_RESETReset or hard reset
KEY_PRINTPrint or copy
KEY_LLHome down or bottom
KEY_A1Upper left of keypad
KEY_A3Upper right of keypad
KEY_B2Center of keypad
KEY_C1Lower left of keypad
KEY_C3Lower right of keypad

The virtual keypad is a 3-by-3 keypad arranged as follows:

A1UPA3
LEFTB2RIGHT
C1DOWNC3

Each legend, such as A1, corresponds to a symbolic constant for a key code from the preceding table, such as KEY_A1. The following symbolic constants representing function key values are also defined:

Key CodeDescription
KEY_BTABBack tab key
KEY_BEGBeginning key
KEY_CANCELCancel key
KEY_CLOSEClose key
KEY_COMMANDCmd (command) key
KEY_COPYCopy key
KEY_CREATECreate key
KEY_ENDEnd key
KEY_EXITExit key
KEY_FINDFind key
KEY_HELPHelp key
KEY_MARKMark key
KEY_MESSAGEMessage key
KEY_MOVEMove key
KEY_NEXTNext object key
KEY_OPENOpen key
KEY_OPTIONSOptions key
KEY_PREVIOUSPrevious object key
KEY_REDORedo key
KEY_REFERENCEReference key
KEY_REFRESHRefresh key
KEY_REPLACEReplace key
KEY_RESTARTRestart key
KEY_RESUMEResume key
KEY_SAVESave key
KEY_SBEGShifted beginning key
KEY_SCANCELShifted cancel key
KEY_SCOMMANDShifted command key
KEY_SCOPYShifted copy key
KEY_SCREATEShifted create key
KEY_SDCShifted delete char key
KEY_SDLShifted delete line key
KEY_SELECTSelect key
KEY_SENDShifted end key
KEY_SEOLShifted clear line key
KEY_SEXITShifted exit key
KEY_SFINDShifted find key
KEY_SHELPShifted help key
KEY_SHOMEShifted home key
KEY_SICShifted input key
KEY_SLEFTShifted left arrow key
KEY_SMESSAGEShifted message key
KEY_SMOVEShifted move key
KEY_SNEXTShifted next key
KEY_SOPTIONSShifted options key
KEY_SPREVIOUSShifted prev key
KEY_SPRINTShifted print key
KEY_SREDOShifted redo key
KEY_SREPLACEShifted replace key
KEY_SRIGHTShifted right arrow
KEY_SRSUMEShifted resume key
KEY_SSAVEShifted save key
KEY_SSUSPENDShifted suspend key
KEY_SUNDOShifted undo key
KEY_SUSPENDSuspend key
KEY_UNDOUndo key

Function Prototypes

The following are declared as functions, and may also be defined as macros:

int addch(const chtype ch); int addchstr(const chtype *chstr); int addchnstr(const chtype *chstr, int n); int addnstr(const char *str, int n); int addstr(const char *str); int addnwstr(const wchar_t *wstr, int n); int addwstr(const wchar_t *wstr); int add_wch(const cchar_t *wch); int add_wchnstr(const cchar_t *wchstr, int n); int add_wchstr(const cchar_t *wchstr); int attroff(int attrs); int attron(int attrs); int attrset(int attrs); int attr_get(attr_t *attrs, short *color_pair, void *opts); int attr_off(attr_t attrs, void *opts); int attr_on(attr_t attrs, void *opts); int attr_set(attr_t attrs, short color_pair, void *opts); int baudrate(void); int beep(void); int bkgd(chtype ch); void bkgdset(chtype ch); void bkgrndset(const cchar_t *wch); int bkgrnd(const cchar_t *wch); int border(chtype ls, chtype rs, chtype ts, chtype bs, chtype tl, chtype tr, chtype bl, chtype br); int border_set(const cchar_t *ls, const cchar_t *rs, const cchar_t *ts, const cchar_t *bs, const cchar_t *tl, const cchar_t *tr, const cchar_t *bl, const cchar_t *br); int box(WINDOW *win, chtype verch, chtype horch); int box_set(WINDOW *win, const cchar_t *verch, const cchar_t *horch); bool can_change_color(void); int cbreak(void); int chgat(int n, attr_t attr, short color, const void *opts); int clear(void); int clearok(WINDOW *win, bool bf); int clrtobot(void); int clrtoeol(void); int color_content(short color, short *red, short *green, short *blue); int COLOR_PAIR(int n); int copywin(const WINDOW *srcwin, WINDOW *dstwin, int sminrow, int smincol, int dminrow, int dmincol, int dmaxrow, int dmaxcol, int overlay); int curs_set(int visibility); int def_prog_mode(void); int def_shell_mode(void); int delay_output(int ms); int delch(void); void delscreen(SCREEN *sp); int delwin(WINDOW *win); int deleteln(void); WINDOW *derwin(WINDOW *orig, int nlines, int ncols, int begin_y, int begin_x); int doupdate(void); WINDOW *dupwin(WINDOW *win); int echo(void); int echochar(const chtype ch); int echo_wchar(const cchar_t *wch); int endwin(void); int erase(void); char erasechar(void); int erasewchar(wchar_t *ch); void filter(void); int flash(void); int flushinp(void); chtype getbkgd(WINDOW *win); int getbkgrnd(cchar_t *wch); int getcchar(const cchar_t *wcval, wchar_t *wch, attr_t *attrs, short *color_pair, void *opts); int getch(void); int getnstr(char *str, int n); int getn_wstr(wint_t *wstr, int n); int getstr(char *str); int get_wch(wint_t *ch); WINDOW *getwin(FILE *filep); int get_wstr(wint_t *wstr); int halfdelay(int tenths); bool has_colors(void); bool has_ic(void); bool has_il(void); int hline(chtype ch, int n); int hline_set(const cchar_t *wch, int n); void idcok(WINDOW *win, bool bf); int idlok(WINDOW *win, bool bf); void immedok(WINDOW *win, bool bf); chtype inch(void); int inchnstr(chtype *chstr, int n); int inchstr(chtype *chstr); WINDOW *initscr(void); int init_color(short color, short red, short green, short blue); int init_pair(short pair, short f, short b); int innstr(char *str, int n); int innwstr(wchar_t *wstr, int n); int insch(chtype ch); int insdelln(int n); int insertln(void); int insnstr(const char *str, int n); int insstr(const char *str); int instr(char *str); int ins_nwstr(const wchar_t *wstr, int n); int ins_wch(const cchar_t *wch); int ins_wstr(const wchar_t *wstr); int intrflush(WINDOW *win, bool bf); int in_wch(cchar_t *wcval); int in_wchstr(cchar_t *wchstr); int in_wchnstr(cchar_t *wchstr, int n); int inwstr(wchar_t *wstr); bool isendwin(void); bool is_linetouched(WINDOW *win, int line); bool is_wintouched(WINDOW *win); char *keyname(int c); char *key_name(wchar_t c); int keypad(WINDOW *win, bool bf); char killchar(void); int killwchar(wchar_t *ch); int leaveok(WINDOW *win, bool bf); char *longname(void); int meta(WINDOW *win, bool bf); int move(int y, int x); int mvaddch(int y, int x, const chtype ch); int mvaddchnstr(int y, int x, const chtype *chstr, int n); int mvaddchstr(int y, int x, const chtype *chstr); int mvaddnstr(int y, int x, const char *str, int n); int mvaddnwstr(int y, int x, const wchar_t *wstr, int n); int mvaddstr(int y, int x, const char *str); int mvaddwstr(int y, int x, const wchar_t *wstr); int mvadd_wch(int y, int x, const cchar_t *wch); int mvadd_wchnstr(int y, int x, const cchar_t *wchstr, int n); int mvadd_wchstr(int y, int x, const cchar_t *wchstr); int mvchgat(int y, int x, int n, attr_t attr, short color, const void *opts); int mvcur(int oldrow, int oldcol, int newrow, int newcol); int mvdelch(int y, int x); int mvderwin(WINDOW *win, int par_y, int par_x); int mvgetch(int y, int x); int mvgetnstr(int y, int x, char *str, int n); int mvgetn_wstr(int y, int x, wint_t *wstr, int n); int mvgetstr(int y, int x, char *str); int mvget_wch(int y, int x, wint_t *ch); int mvget_wstr(int y, int x, wint_t *wstr); int mvhline(int y, int x, chtype ch, int n); int mvhline_set(int y, int x, const cchar_t *wch, int n); chtype mvinch(int y, int x); int mvinchnstr(int y, int x, chtype *chstr, int n); int mvinchstr(int y, int x, chtype *chstr); int mvinnstr(int y, int x, char *str, int n); int mvinnwstr(int y, int x, wchar_t *wstr, int n); int mvinsch(int y, int x, chtype ch); int mvinsnstr(int y, int x, const char *str, int n); int mvinsstr(int y, int x, const char *str); int mvinstr(int y, int x, char *str); int mvins_nwstr(int y, int x, const wchar_t *wstr, int n); int mvins_wch(int y, int x, const cchar_t *wch); int mvins_wstr(int y, int x, const wchar_t *wstr); int mvinwstr(int y, int x, wchar_t *wstr); int mvin_wch(int y, int x, cchar_t *wcval); int mvin_wchnstr(int y, int x, cchar_t *wchstr, int n); int mvin_wchstr(int y, int x, cchar_t *wchstr); int mvprintw(int y, int x, char *fmt, ...); int mvscanw(int y, int x, char *fmt, ...); int mvvline(int y, int x, chtype ch, int n); int mvvline_set(int y, int x, const cchar_t *wch, int n); int mvwaddch(WINDOW *win, int y, int x, const chtype ch); int mvwaddchnstr(WINDOW *win, int y, int x, const chtype *chstr, int n); int mvwaddchstr(WINDOW *win, int y, int x, const chtype *chstr); int mvwaddnstr(WINDOW *win, int y, int x, const char *str, int n); int mvwaddnwstr(WINDOW *win, int y, int x, const wchar_t *wstr, int n); int mvwaddstr(WINDOW *win, int y, int x, const char *str); int mvwaddwstr(WINDOW *win, int y, int x, const wchar_t *wstr); int mvwadd_wch(WINDOW *win, int y, int x, const cchar_t *wch); int mvwadd_wchnstr(WINDOW *win, int y, int x, const cchar_t *wchstr, int n); int mvwadd_wchstr(WINDOW *win, int y, int x, const cchar_t *wchstr); int mvwchgat(WINDOW *win, int y, int x, int n, attr_t attr, short color, const void *opts); int mvwdelch(WINDOW *win, int y, int x); int mvwgetch(WINDOW *win, int y, int x); int mvwgetnstr(WINDOW *win, int y, int x, char *str, int n); int mvwgetn_wstr(WINDOW *win, int y, int x, wint_t *wstr, int n); int mvwgetstr(WINDOW *win, int y, int x, char *str); int mvwget_wch(WINDOW *win, int y, int x, wint_t *ch); int mvwget_wstr(WINDOW *win, int y, int x, wint_t *wstr); int mvwhline(WINDOW *win, int y, int x, chtype ch, int n); int mvwhline_set(WINDOW *win, int y, int x, const cchar_t *wch, int n); int mvwin(WINDOW *win, int y, int x); chtype mvwinch(WINDOW *win, int y, int x); int mvwinchnstr(WINDOW *win, int y, int x, chtype *chstr, int n); int mvwinchstr(WINDOW *win, int y, int x, chtype *chstr); int mvwinnstr(WINDOW *win, int y, int x, char *str, int n); int mvwinnwstr(WINDOW *win, int y, int x, wchar_t *wstr, int n); int mvwinsch(WINDOW *win, int y, int x, chtype ch); int mvwinsnstr(WINDOW *win, int y, int x, const char *str, int n); int mvwinsstr(WINDOW *win, int y, int x, const char *str); int mvwinstr(WINDOW *win, int y, int x, char *str); int mvwins_nwstr(WINDOW *win, int y, int x, const wchar_t *wstr, int n); int mvwins_wch(WINDOW *win, int y, int x, const cchar_t *wch); int mvwins_wstr(WINDOW *win, int y, int x, const wchar_t *wstr); int mvwinwstr(WINDOW *win, int y, int x, wchar_t *wstr); int mvwin_wch(WINDOW *win, int y, int x, cchar_t *wcval); int mvwin_wchnstr(WINDOW *win, int y, int x, cchar_t *wchstr, int n); int mvwin_wchstr(WINDOW *win, int y, int x, cchar_t *wchstr); int mvwprintw(WINDOW *win, int y, int x, char *fmt, ...); int mvwscanw(WINDOW *win, int y, int x, char *fmt, ...); int mvwvline(WINDOW *win, int y, int x, chtype ch, int n); int mvwvline_set(WINDOW *win, int y, int x, const cchar_t *wch, int n); int napms(int ms); WINDOW *newpad(int nlines, int ncols); SCREEN *newterm(char *type, FILE *outfile, FILE *infile); WINDOW *newwin(int nlines, int ncols, int begin_y, int begin_x); int nl(void); int nonl(void); int nocbreak(void); int nodelay(WINDOW *win, bool bf); int noecho(void); void noqiflush(void); int noraw(void); int notimeout(WINDOW *win, bool bf); int overlay(const WINDOW *srcwin, WINDOW *dstwin); int overwrite(const WINDOW *srcwin, WINDOW *dstwin); int pair_content(short pair, short *f, short *b); int PAIR_NUMBER(int value); int pechochar(WINDOW *pad, chtype *ch); int pecho_wchar(WINDOW *pad, const cchar_t *wch); int pnoutrefresh(WINDOW *pad, int pminrow, int pmincol, int sminrow, int smincol, int smaxrow, int smaxcol); int prefresh(WINDOW *pad, int pminrow, int pmincol, int sminrow, int smincol, int smaxrow, int smaxcol); int printw(char *fmt, ...); int putp(const char *str); int putwin(WINDOW *win, FILE *filep); void qiflush(void); int raw(void); int redrawwin(WINDOW *win); int refresh(void); int resetty(void); int reset_prog_mode(void); int reset_shell_mode(void); int ripoffline(int line, int (*init)(WINDOW *win, int columns)); int savetty(void); int scanw(char *fmt, ...); int scr_dump(const char *filename); int scr_init(const char *filename); int scrl(int n); int scroll(WINDOW *win); int scrollok(WINDOW *win, bool bf); int scr_restore(const char *filename); int scr_set(const char *filename); int setcchar(cchar_t *wcval, const wchar_t *wch, const attr_t attrs, short color_pair, const void *opts); int setscrreg(int top, int bot); SCREEN *set_term(SCREEN *new); int slk_attroff(const chtype attrs); int slk_attr_off(const attr_t attrs, void *opts); int slk_attron(const chtype attrs); int slk_attr_on(const attr_t attrs, void *opts); int slk_attrset(const chtype attrs); int slk_attr_set(const attr_t attrs, short color_pair, void *opts); int slk_clear(void); int slk_init(int fmt); char *slk_label(int labnum); int slk_noutrefresh(void); int slk_refresh(void); int slk_restore(void); int slk_set(int labnum, const char *label, int justify); int slk_touch(void); int slk_wset(int labnum, const wchar_t *label, int justify); int standend(void); int standout(void); int start_color(void); WINDOW *subpad(WINDOW *orig, int nlines, int ncols, int begin_y, int begin_x); WINDOW *subwin(WINDOW *orig, int nlines, int ncols, int begin_y, int begin_x); int syncok(WINDOW *win, bool bf); chtype termattrs(void); attr_t term_attrs(void); char *termname(void); int tigetflag(char *capname); int tigetnum(char *capname); char *tigetstr(char *capname); void timeout(int delay); int touchline(WINDOW *win, int start, int count); int touchwin(WINDOW *win); char *tparm(char *cap, long p1, long p2, long p3, long p4, long p5, long p6, long p7, long p8, long p9); int typeahead(int fildes); int ungetch(int ch); int unget_wch(const wchar_t wch); int untouchwin(WINDOW *win); void use_env(bool boolvalue); int vidattr(chtype attr); int vid_attr(attr_t attr, short color_pair, void *opts); int vidputs(chtype attr, int (*putfunc)(int)); int vid_puts(attr_t attr, short color_pair, void *opt, int (*putwfunc)(int)); int vline(chtype ch, int n); int vline_set(const cchar_t *wch, int n); int vwprintw(WINDOW *win, char *fmt, void *varglist); int vw_printw(WINDOW *win, char *fmt, void *varglist); int vwscanw(WINDOW *win, char *fmt, void *varglist); int vw_scanw(WINDOW *win, char *fmt, void *varglist); int waddch(WINDOW *win, const chtype ch); int waddchnstr(WINDOW *win, const chtype *chstr, int n); int waddchstr(WINDOW *win, const chtype *chstr); int waddnstr(WINDOW *win, const char *str, int n); int waddnwstr(WINDOW *win, const wchar_t *wstr, int n); int waddstr(WINDOW *win, const char *str); int waddwstr(WINDOW *win, const wchar_t *wstr); int wadd_wch(WINDOW *win, const cchar_t *wch); int wadd_wchnstr(WINDOW *win, const cchar_t *wchstr, int n); int wadd_wchstr(WINDOW *win, const cchar_t *wchstr); int wattroff(WINDOW *win, int attrs); int wattron(WINDOW *win, int attrs); int wattrset(WINDOW *win, int attrs); int wattr_get(WINDOW *win, attr_t *attrs, short *color_pair, void *opts); int wattr_off(WINDOW *win, attr_t attrs, void *opts); int wattr_on(WINDOW *win, attr_t attrs, void *opts); int wattr_set(WINDOW *win, attr_t attrs, void *opts); int wbkgd(WINDOW *win, chtype ch); void wbkgdset(WINDOW *win, chtype ch); int wbkgrnd(WINDOW *win, const cchar_t *wch); void wbkgrndset(WINDOW *win, const cchar_t *wch); int wborder(WINDOW *win, chtype ls, chtype rs, chtype ts, chtype bs, chtype tl, chtype tr, chtype bl, chtype br); int wborder_set(WINDOW *win, const cchar_t *ls, const cchar_t *rs, const cchar_t *ts, const cchar_t *bs, const cchar_t *tl, const cchar_t *tr, const cchar_t *bl, const cchar_t *br); int wchgat(WINDOW *win, int n, attr_t attr, short color, const void *opts); int wclear(WINDOW *win); int wclrtobot(WINDOW *win); int wclrtoeol(WINDOW *win); void wcursyncup(WINDOW *win); int wdelch(WINDOW *win); int wdeleteln(WINDOW *win); int wechochar(WINDOW *win, const chtype ch); int wecho_wchar(WINDOW *win, const cchar_t *wch); int werase(WINDOW *win); int wgetbkgrnd(WINDOW *win, cchar_t *wch); int wgetch(WINDOW *win); int wgetnstr(WINDOW *win, char *str, int n); int wgetn_wstr(WINDOW *win, wint_t *wstr, int n); int wgetstr(WINDOW *win, char *str); int wget_wch(WINDOW *win, wint_t *ch); int wget_wstr(WINDOW *win, wint_t *wstr); int whline(WINDOW *win, chtype ch, int n); int whline_set(WINDOW *win, const cchar_t *wch, int n); chtype winch(WINDOW *win); int winchnstr(WINDOW *win, chtype *chstr, int n); int winchstr(WINDOW *win, chtype *chstr); int winnstr(WINDOW *win, char *str, int n); int winnwstr(WINDOW *win, wchar_t *wstr, int n); int winsch(WINDOW *win, chtype ch); int winsdelln(WINDOW *win, int n); int winsertln(WINDOW *win); int winsnstr(WINDOW *win, const char *str, int n); int winsstr(WINDOW *win, const char *str); int winstr(WINDOW *win, char *str); int wins_nwstr(WINDOW *win, const wchar_t *wstr, int n); int wins_wch(WINDOW *win, const cchar_t *wch); int wins_wstr(WINDOW *win, const wchar_t *wstr); int winwstr(WINDOW *win, wchar_t *wstr); int win_wch(WINDOW *win, cchar_t *wcval); int win_wchnstr(WINDOW *win, cchar_t *wchstr, int n); int win_wchstr(WINDOW *win, cchar_t *wchstr); int wmove(WINDOW *win, int y, int x); int wnoutrefresh(WINDOW *win); int wprintw(WINDOW *win, char *fmt, ...); int wredrawln(WINDOW *win, int beg_line, int num_lines); int wrefresh(WINDOW *win); int wscanw(WINDOW *win, char *fmt, ...); int wscrl(WINDOW *win, int n); int wsetscrreg(WINDOW *win, int top, int bot); int wstandend(WINDOW *win); int wstandout(WINDOW *win); void wsyncdown(WINDOW *win); void wsyncup(WINDOW *win); void wtimeout(WINDOW *win, int delay); int wtouchln(WINDOW *win, int y, int n, int changed); wchar_t *wunctrl(cchar_t *wc); int wvline(WINDOW *win, chtype ch, int n); int wvline_set(WINDOW *win, const cchar_t *wch, int n);

APPLICATION USAGE

In order to support historical applications that include <curses.h> and use <varargs.h> the following interfaces using va_list are declared as having a third argument of type (void *): vw_printw(), vw_scanw(), vwprintw(), vwscanw().

SEE ALSO

curses_intro(3X), <stdio.h>, <term.h>, <termios.h>, <unctrl.h>, <wchar.h>.

X/Open System Interfaces and Headers, Issue 4, Version 2 specification.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.