Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > S

setboot(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

setboot — display and modify boot variables in stable storage

SYNOPSIS

setboot [-p primary-path] [-h HA_alternate-path] [-a alternate-path] [-b on|off] [-s on|off] [-m on|off] [-r] [-v] [-t testname= on|off|default]... [-T testname= on|off|default]...

DESCRIPTION

The setboot command displays and sets boot variables in stable storage (also known as nonvolatile memory). Any user can display the values; only a superuser can change them.

On all systems, the variables are: primary path, alternate path, HA alternate path (if applicable; see -h option), autoboot flag, and autosearch flag. If SpeedyBoot is installed, the variables expand to include: early CPU tests, late CPU tests, memory initialization (on Integrity systems), full memory tests, processor hardware tests (on PA-RISC), platform dependent tests (on Integrity systems), IO Hardware tests (on Integrity systems), chipset tests (on Integrity systems), and central electronic complex tests (on PA-RISC), hyperthreading (on some Integrity systems).

With no options, setboot displays the current values for the primary boot path, alternate boot path, HA alternate boot path, and the autoboot and autosearch flags. If SpeedyBoot is installed, setboot -v also displays the status of the CPU, memory, hardware, and electronics tests. If the platform supports hyperthreading, setboot displays whether processor hyperthreading is enabled/disabled for current and subsequent system boots.

SpeedyBoot

The SpeedyBoot firmware and software extensions allows a superuser to control which firmware tests are executed by the system during the boot process. The tests settings can be specified both for all subsequent boots and for the next one only. They are described in the The Tests section below.

The -v, -t, and -T options of the setboot command provide the user interface to the firmware tests. Currently -t options is not supported on Integrity system architecture.

SpeedyBoot augments the test control that is available on systems that have the Boot Console Handler (BCH). By turning off some or all of the boot tests, you can shorten boot time appreciably. However, in the event of a system panic or boot failure, all tests are executed on the subsequent boot.

SpeedyBoot Tests

The SpeedyBoot tests and the possible display values on a PA-RISC platform are summarized in the following table:

TestCurrentSupportedDefaultNEXT BOOT
allon|off|partialyes|no|partialon|off|partialon|off|partial
SELFTESTSon|off|partialyes|no|partialon|off|partialon|off|partial
early_cpuon|offyes|noon|offon|off
late_cpuon|offyes|noon|offon|off
FASTBOOTon|off|partialyes|no|partialon|off|partialon|off|partial
full_memoryon|offyes|noon|offon|off
PDHon|offyes|noon|offon|off
on|off    
CECon|offyes|noon|offon|off
on|off    

The SpeedyBoot tests and the possible display values on an Integrity platform are summarized in the following table:

TestCurrentDefault  
allon|off|partialon|off|partial  
SELFTESTSon|off|partialon|off|partial  
early_cpuon|offon|off  
late_cpuon|offon|off  
FASTBOOTon|off|partialon|off|partial  
Platformon|offon|off  
Full_memoryon|offon|off  
Memory_initon|offon|off  
IO_HWon|offon|off  
Chipseton|offon|off  

The Columns

Test

The keyword names of the tests that can be controlled by SpeedyBoot. See The Tests section below.

Current

The current enablement of each test. on means the test is normally executed on each boot. off means the test is normally omitted on each boot. partial means some of the subtests are normally executed on each boot. On Integrity platform any test modified using the -T option will be reflected in Current.

Supported

Whether the test is supported by the system firmware. yes means the test is supported. no means the test is not supported. partial means some of the subtests are supported. On Integrity platform, this Column is not supported.

Default

The default values for each test. on, off, and partial are the same as for Current.

NEXT BOOT

The values for each test that will be used on the next boot. If they are different from Current, the Current values will be reestablished after the next boot. on, off, and partial are the same as for Current. On Integrity platform, this Column is same as that of Current and hence not displayed separately.

The Tests

These are keywords for the hardware tests that are executed by processor-dependent code (PDC) or firmware upon a boot or reboot of the system.

all

All the listed tests.

SELFTESTS

Includes the early_cpu and late_cpu tests. This is equivalent to the SELFTESTS option in the boot console handler (BCH) service menu. The difference is that setboot can control the subtests separately, while BCH cannot.

early_cpu

When on, run firmware, cache, and CPU-specific tests. Performed out of firmware. When off, skip the tests.

late_cpu

When on, run firmware, cache, and CPU-specific tests. Performed out of memory and therefore faster than the early_cpu tests. When off, skip the tests.

FASTBOOT

Includes the full_memory and PDH tests on PA-RISC Platform. Includes the Platform and Full_memory tests on Integrity platform. This is equivalent to the FASTBOOT option in the boot console handler (BCH) service menu. The difference is that setboot can control the subtests separately, while BCH cannot.

Note: When FASTBOOT is on, the tests are performed, and vice versa.

full_memory

When on, run write/read-write/read tests on all memory locations. When off, only initialize memory. Supported only on PA-RISC Platform.

Platform

When on, enables general platform hardware tests. When off, do not. Supported only on Integrity platform.

Full_memory

When on, enables full destructive memory tests. When off, do not. Supported only on Integrity platform.

PDH

Processor-dependent hardware. When on, test a checksum of read-only memory (ROM). When off, do not. Supported only on PA-RISC Platform.

CEC

Central electronic complex. When on, test low-level bus converters and I/O chips. When off, do not. CEC is not available on all systems. Supported only on PA-RISC Platform.

Memory_init

When on, enables full destructive memory tests. When off, do not. Supported only on Integrity platform.

IO_HW

IO Hardware. When on, enables system firmware, or EFI drivers to perform all the tests of IO hardware (boot devices only). When off, do not. Supported only on Integrity platform.

Chipset

When on, enables Chipset tests. When off, does not enable Chipset tests. Supported only on Integrity platform.

Hyperthreading

Some Integrity processors support chip level multiprocessing which is a physical core presenting itself as two (or possibly more) logical CPUs (or hardware threads). Hyperthreading increases the instruction throughput by making use of the idle cycles and idle functional units that occur due to stalls.

Supported on some Integrity platform.

Failover

setboot will support boot path failover irrespective of whether a persistent device special file, lunpath hardware path, or legacy hardware path is given as input.

A persistent device special file is associated with a device based on its worldwide identifier, rather than its physical hardware path. When a persistent device special file is given as input, setboot writes an available lunpath hardware path to the LUN into stable storage.

Note: There is no order in which the available lunpath hardware paths get selected. Also, when the same persistent device special file is given as input for more than one boot path, setboot will avoid setting the same lunpath for the concerned boot paths.

When a lunpath hardware path is given as input, setboot writes that path into stable storage.

When a legacy hardware path is given as input, setboot writes the corresponding lunpath hardware path into stable storage. For more information on legacy hardware path and lunpath hardware path mapping, see ioscan(1M).

For more information on Hardware Paths and Device File Naming Conventions, including persistent device special file names, see intro(7).

If the hardware path written into stable storage goes offline, setboot retrieves an alternate available hardware path to the LUN and writes that path into stable storage. setboot supports failover by subscribing to the health of the hardware path that it writes to stable storage using EVM (see EVM(5)).

Options

The setboot command supports the following options:

(none)

Display the current values for the primary, HA alternate (if applicable) and alternate boot paths and the autoboot and autosearch flags. See example 2 in the EXAMPLES: General section.

-p primary-path

Set the primary boot path variable to primary-path. setboot will accept legacy hardware paths, lunpath hardware paths, and persistent device special files as valid input (see intro(7)).

-h HA_alternate-path

Set the High Availability alternate boot path variable to HA_alternate-path. setboot will accept legacy hardware paths, lunpath hardware paths, and persistent device special files as valid input (see intro(7)).

High Availability alternate boot path is supported only on Integrity system architecture and for PA-RISC systems that support hardware partitions.

-a alternate-path

Set the alternate boot path variable to alternate-path. setboot will accept legacy hardware paths, lunpath hardware paths, and persistent device special files as valid input (see intro(7)).

-r

Reinitialize the EVM subscription for boot paths currently set in stable storage. This option is useful when the boot path health event subscriptions are not updated after a change in boot paths. For example, when the boot paths are updated between an evmd stop and restart. See evmd(1M). Refer to the Failover section for more information.

-s on|off

Enable or disable the autosearch sequence. The interpretation of Autoboot and Autosearch has changed for PA-RISC systems that support hardware partitions. Refer to the WARNINGS section. The -s option is not supported on Integrity system architecture.

-b on|off

Enable or disable the autoboot sequence. The interpretation of Autoboot and Autosearch has changed for PA-RISC systems that support hardware partitions. Refer to the WARNINGS section.

-m on|off

Enable or disable hyperthreading. -m option is supported only on Integrity system architecture.

-v

Display the current values for the primary and alternate boot paths and the autoboot and autosearch flags and a status table of the SpeedyBoot tests. See example 1 in the EXAMPLES: SpeedyBoot section.

-t testname=value

Change the value for the test testname in stable storage to value for all following boots. -t option is not supported on Integrity system architecture. The changes are reflected in the Current" and NEXT BOOT columns of the setboot -v display.

testname can be one of the following keywords, as described above in the DESCRIPTION: SpeedyBoot Tests section.

all SELFTESTS early_cpu late_cpu FASTBOOT full_memory PDH CEC

value can be one of:

on

Enable the test.

off

Disable the test.

default

Reset the test to the system default, which is shown in the Defaults column of the setboot -v display.

-T testname=value

Change the value for the test testname to value for the next system boot only. The change does not modify stable storage, so the permanent values are restored after the boot.

testname can be one of the keywords described above in the DESCRIPTION: SpeedyBoot Tests section. and value are the same as for the -t option.

RETURN VALUE

The setboot command returns one of:

0

Successful completion

1

Failure

DIAGNOSTICS

The setboot command returns the following error messages:

" bootpath " is not a valid bootpath. Bootpaths should be specified with a persistent dsf, lunpath hardware path or a legacy hardware path.

  • The boot path, bootpath, should be one of the following: persistent LUN dsf, lunpath hardware path or legacy hardware path. See ioscan(1M) and intro(7) for more information on hardware path and persistent dsf format.

cannot open /dev/kepd - message

  • setboot cannot open the kernel pseudo driver file /dev/kepd. The message explains why.

cannot set autoboot/autosearch flags

  • The autoboot or autosearch flag could not be set.

cannot set type boot path

  • setboot can't set the specified boot path. type may be primary, HA_alternate, or alternate.

error accessing boot path - message

  • The message explains why. For example, you may not have permission (not be superuser) to change parameters.

error accessing firmware - message

  • The firmware could not be read or written. The message explains why.

Failed to retrieve lun token

  • An error occurs when one of the boot paths is invalid (when running setboot -r or /sbin/init.d/setboot). This kind of error occurs when there is no valid LUN entry corresponding to the boot path or lunpath.

No dsf found

  • An error occurs when displaying boot paths when there is no valid LUN entry corresponding to the boot path. For example, one or more of these situations has occurred regarding the persistent LUN dsf entry:

    • The persistent LUN dsf corresponding to the boot path (lunpath in stable storage) has been removed (most likely with the rmsf command).

    • The boot path is set to a lunpath, but the associated HBA to that lunpath has been removed or disabled.

    • The boot path is set to a non-existent or invalid boot device in the I/O system.

Invalid Arguments Passed to the invoked PDC routine

  • This is an internal error.

test not found in /etc/setboot_tests file

  • The test you specified is not defined for your system.

The firmware of your system does not support querying or changing SELFTEST and FASTBOOT settings except through the boot-time console interface, ie, BCH menu. Invoked PDC routine [option] not implemented. (On PA-RISC Platform only.)

or

The firmware of your system does not support querying or changing the SpeedyBoot settings. (On Integrity platform only.)

  • You have specified a SpeedyBoot option (-t, -T, or -v) and your system does not have the firmware to support SpeedyBoot. Currently, the Integrity platform does not support -t options.

Unknown error errornum encountered by setboot(1M)

  • An unexpected error, number errornum, was encountered while setboot was processing SpeedyBoot parameters.

Warning: Autoboot flag must be on for autosearch flag to have effect

  • If the autoboot flag is off, automatic searching for a bootable system cannot occur, even if the autosearch flag is on.

warning: invalid data in /etc/setboot_tests

  • The /etc/setboot_tests file contains tests that are not supported by setboot on your system. Do not modify this file.

EXAMPLES

General

1.

Set the primary path to 2/4.1.0 and enable the autoboot sequence:

setboot -p 2/4.1.0 -b on

2.

Set the alternate path (using a persistent device special file) to /dev/disk/disk2 and enable the autoboot sequence:

setboot -a /dev/disk/disk2 -b on

setboot displays:

Alternate boot path set to 0/0/0/3/0.0x6.0x0 (/dev/disk/disk2)

3.

Display the boot paths, auto flags and hyperthreading:

setboot

on PA-RISC and Integrity system architecture displays:

Primary bootpath : 0/0/0/3/0.0x5.0x0 (/dev/rdisk/disk3) HA Alternate bootpath : 0/0/0/3/0.0x6.0x0 (/dev/rdisk/disk2) Alternate bootpath : 0/0/0/3/0.0x6.0x0 (/dev/rdisk/disk2) Autoboot is ON (enabled) Autosearch is ON (enabled)

  • on Integrity system architecture which support hardware threads displays:

    Primary bootpath : 0/3/2/0.0x50001fe15002c7f9.0x4001000000000000 (/dev/rdisk/disk7) HA Alternate bootpath : 0/1/1/1.0x0.0x0 (/dev/rdisk/disk10) Alternate bootpath : 0/1/1/0.0x1.0x0 (/dev/rdisk/disk9) Autoboot is ON (enabled) Hyperthreading : ON : ON (next boot)

SpeedyBoot

1.

Display all current stable storage values.

setboot -v

on PA-RISC architecture displays:

Primary bootpath : 0/0/0/3/0.0x5.0x0 (/dev/rdisk/disk3) HA Alternate bootpath : 0/0/0/3/0.0x6.0x0 (/dev/rdisk/disk2) Alternate bootpath : 0/0/0/3/0.0x6.0x0 (/dev/rdisk/disk2) Autoboot is ON (enabled) Autosearch is OFF (disabled) TEST CURRENT SUPPORTED DEFAULT NEXT BOOT ---- ------- --------- ------- --------- all partial partial partial partial SELFTESTS partial yes on partial early_cpu off yes on off late_cpu on yes on on FASTBOOT partial yes on partial full_memory off yes on off PDH on yes on on CEC off no off off

on Integrity system architecture displays:

Primary bootpath : 0/1/1/0.0x1.0x0 (/dev/rdisk/disk9) HA Alternate bootpath : 0/1/1/1.0x0.0x0 (/dev/rdisk/disk10) Alternate bootpath : 0/1/1/1.0x0.0x0 (/dev/rdisk/disk10) Autoboot is ON (enabled) TEST CURRENT DEFAULT ---- ------- ------- all partial partial SELFTESTS off on early_cpu off on late_cpu off on FASTBOOT on on Platform on on Full_memory on on Memory_init on on IO_HW off off Chipset on on

2.

Enable full_memory and PDH tests and have those tests executed on all subsequent reboots.

setboot -t FASTBOOT=on

3.

Disable the late processor tests and have those tests skipped on all subsequent reboots. If early CPU tests are on when this command is executed, the SELFTESTS state in BCH stays on while setboot -v shows the state as partial.

setboot -t late_cpu=off

4.

Reset all tests to the machine-shipped default values.

setboot -t all=default

5.

Reset only the FASTBOOT (full_memory and PDH) tests to their default values.

setboot -t FASTBOOT=default

6.

Cause the early and late CPU tests to be executed on the next system boot. The previously set test values take effect again after the single boot.

setboot -T SELFTESTS=on

7.

Cause all tests to be skipped on the next reboot. The previously set test values will take effect for subsequent reboots.

setboot -T all=off

8.

Enable hyperthreading for next system boot.

setboot -m on

WARNINGS

The setboot command fails under the following circumstances:

  • On Integrity systems, a device cannot be set as a boot path if the device does not have an EFI partition.

  • The number of writes to the stable storage exceeds the number allowed by the architecture implementation.

  • Hardware failure.

  • The implementation does not have memory for the alternate boot path, in which case, this variable is neither readable nor writable.

Autoboot and Autosearch on PA-RISC Systems

The interpretation of Autoboot and Autosearch has changed for PA-RISC systems that support hardware partitions. The firmware interprets the bits in combination and not individually as done before. In order to approximate the traditional behavior of setboot, the user input for the autoboot and autosearch flags is internally mapped to the right combination to achieve the desired behavior. This mapping should be transparent to the user of setboot, but might show up when accessing the firmware using means other than setboot.

For the primary path, the boot action corresponds to the Autoboot and Autosearch flags in the following manner:

AutoBootAutoSearchBoot Action
offoffGo to the BCH and prompt the user.
onoffAttempt the primary path; on failure
go to BCH.
ononAttempt the primary path; on failure
try next path.
offonSkip the primary path and try alternate path.
If the alternate paths are not configured to
boot or fail, go to BCH.

Additionally, systems with hardware partitions support a boot action for each path. However the boot action for the paths other than the primary path cannot be set using setboot. Instead, these must be set through the Boot Console Handler using the pf (path flags) command of the BCH Configuration menu. The default boot action for the hardware partitions is to "skip this device and try next path". The case where both the autosearch and autoboot flags are on, will not work as expected until the path flags for the alternate paths are set appropriately through the BCH. In the default case, specifying setboot -b on -s on will not cause an alternate path to be automatically booted when the primary path fails, instead the user will be prompted.

DEPENDENCIES

If SpeedyBoot is not installed on a system, options -v, -t, and -T will produce a diagnostic error. Currently -t option is not supported on Integrity system architecture.

If the platform does not support hyperthreading, then the -m option will produce a diagnostic error.

AUTHOR

setboot was developed by HP.

FILES

/dev/kepd

Special device file used by the setboot command.

/var/evm/adm/config/logger/setboot*.conf

Secondary EVM logger configuration files for setboot.

/etc/setboot_tests

Definitions of tests which can be viewed or controlled with the -v, -t, and -T options.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.