Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > S

setoncenv(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

setoncenv — NFS environment configuration command

SYNOPSIS

/usr/sbin/setoncenv [-av] variable value

/usr/sbin/setoncenv -l[v] [subsystem|variable]

/usr/sbin/setoncenv -r[v] variable [value]

DESCRIPTION

setoncenv initializes, displays, and removes the value of NFS configuration variables, found either in /etc/rc.config.d/nfsconf, /etc/rc.config.d/namesvrs, /etc/default/autofs, /etc/default/key, /etc/default/nfs, or /etc/default/nfslogd. The value can be an integer or a string and should be consistent with the variable being set. There is limited validation of the value parameter. Quotes should be avoided unless the value can have white space; then quotes should be used. The setoncenv command can also be used to display the NFS kernel tunable variables.

Options

setoncenv recognizes the following flags:

-a

Add a supported configuration variable, or change the value of an existing configuration variable in the configuration file. The -a option cannot be used to set a kernel tunable variable. You must use kctune to manage kernel tunable variables.

-l

Display the values of all configuration variables and kernel tunable variables supported by setoncenv. Optionally you can specify either a subsystem or an individual variable.

-r

Remove or comment out a configuration variable in a configuration file. The setoncenv command will not remove or comment out variables from /etc/rc.config.d/nfsconf or /etc/rc.config.d/namesvrs; it also cannot be used to remove kernel tunable variables. The value parameter is only used when removing an entry for a configuration variable that supports multiple entries in a configuration file (for example, AUTOMOUNTD_ENV).

-v

Provide verbose output.

NOTE: Using a command or editor other than setoncenv to modify the supported configuration files can cause problems if used simultaneously. The setoncenv command will attempt to correct some issues, such as duplicate entries where duplicate entries are not allowed, but there is no guarantee that setoncenv can recover a configuration file once the file has been edited by another process. In the event of duplicate entries in a configuration file, the following precedence is followed. For /etc/rc.config.d/nfsconf and /etc/rc.config.d/namesvrs, the last entry is the value used. For /etc/default/nfs, /etc/default/nfslogd, /etc/default/key, and /etc/default/autofs, the first entry is the value used.

The setoncenv command recognizes the following subsystem names:

autofs

Will display all variables associated with the AutoFS subsystem.

key

Will display all variables associated with the KEY, keyserv subsystem.

klm

Will display all variables associated with the Kernel Lock Manager subsystem.

krpc

Will display all variables associated with the kernel RPC subsystem.

nfs

Will display all variables associated with the NFS subsystem.

nfslogd

Will display all variables associated with the NFS logging, nfslogd subsystem.

nis

Will display all variables associated with the NIS subsystem.

rpcbind

Will display all variables associated with the rpcbind subsystem.

The setoncenv command recognizes the following configuration variable names for the AutoFS subsystem:

AUTO_MASTER [path]

The location of the default auto_master file.

AUTOFS [0 | 1]

Used to enable or disable the AutoFS service during system startup. Can only be 0 to disable the service or 1 to enable the service. This variable will be obsolete in a future release.

AUTOMOUNT_OPTIONS [option_string]

The run time arguments for the automount command used by /sbin/init.d/autofs. This variable will be obsolete in a future release.

AUTOMOUNT_TIMEOUT [number]

Specifies a duration, in seconds, that a file system is to remain mounted when not in use. The default value is 600 (10 minutes). Equivalent to the -t option in automount.

AUTOMOUNT_VERBOSE [TRUE | FALSE]

Verbose mode. Causes you to be notified of non-critical events, such as autofs mounts and unmounts. The default value is FALSE. Equivalent to the -v option in automount.

AUTOMOUNTD_ENV [name=value]

Environment variables. Each environment variable-value pairing must be on its own line. You can specify multiple such pairings. When using the -r option, just specifying AUTOMOUNTD_ENV will remove all variables, using AUTOMOUNTD_ENV name=value will remove that value only.

AUTOMOUNTD_NOBROWSE [TRUE | FALSE]

Turn on or off browsing for all AutoFS mount points. The default value is FALSE. Equivalent to the -n option in automountd.

AUTOMOUNTD_OPTIONS [option_string]

The run time arguments for the automount daemon used by /sbin/init.d/autofs. This variable will be obsolete in a future release.

AUTOMOUNTD_TRACE [number]

Expands each RPC call and displays it on standard output. The default value, 0, turns off such tracing. Tracing starts with value 1 and with each higher value the verbosity of trace output increases.

AUTOMOUNTD_VERBOSE [TRUE | FALSE]

Verbose mode. Causes status messages to be logged to the console. The default value is FALSE. Equivalent to the -v option in automountd.

The setoncenv command recognizes the following configuration variable names for the KEY subsystem:

ENABLE_NOBODY_KEYS [yes | no]

Specifies whether default keys for nobody are used. ENABLE_NOBODY_KEYS=NO is equivalent to the -d command-line option for keyserv. The default value for ENABLE_NOBODY_KEYS is yes.

KEYSERV_OPTIONS [option_string]

The run time arguments for the keyserv daemon used by /sbin/init.d/nis.client or /sbin/init.d/nis.server. This variable will be obsolete in a future release.

The setoncenv command recognizes the following configuration variable names for the Kernel Lock Manager subsystem:

GRACE_PERIOD [number]

Grace period, in seconds, that all clients (both NLM and NFSv4) have to reclaim locks after a server reboot. This variable also controls the NFSv4 lease interval. The default value is 90.

LOCKD_LISTEN_BACKLOG [number]

Set connection queue length for rpc.lockd over a connection-oriented transport. The default value is 32.

LOCKD_OPTIONS [option_string]

The run time arguments for the rpc.lockd daemon used by /sbin/init.d/lockmgr. This variable will be obsolete in a future release.

LOCKD_PORT [number]

Obsolete. The port number rpc.lockd should use for listening for incoming requests.

LOCKD_RETRANSMIT_TIMEOUT [number]

Retransmit timeout, in seconds, before rpc.lockd retries. The default is 5.

LOCKD_SERVERS [number]

Maximum number of concurrent rpc.lockd requests. The default value is 20.

LOCKMGR [0 | 1]

Used to enable or disable the klm service by /sbin/init.d/lockmgr. Value can either be 0 to disable the service or 1 to enable the service. This variable will be obsolete in a future release.

STATD_OPTIONS [option_string]

The run time arguments for the rpc.statd daemon used by /sbin/init.d/lockmgr. This variable will be obsolete in a future release.

STATD_PORT [number]

The port number rpc.statd should use for listening for incoming requests.

The setoncenv command recognizes the following kernel tunable variable names for the kernel RPC subsystem (a complete description of all KRPC kernel tunable variables can be found in the NFS Services Administrator's Guide):

rpc_clnt_idle_timeout

Controls the amount of time on the client a connection can stay idle before being closed.

rpc_clnt_max_conns

Controls the number of TCP connections between an NFS client and an NFS server.

rpc_svc_cltsmaxdupreqs

Controls the size of the duplicate request cache over UDP.

rpc_svc_cotsmaxdupreqs

Controls the size of the duplicate request cache over TCP.

rpc_svc_default_max_same_xprt

Controls the maximum number of requests that are processed for each transport endpoint before switching transport endpoints.

rpc_svc_idle_timeout

Controls the amount of time a connection on the server can stay idle before being closed.

The setoncenv command recognizes the following configuration variable names for the NFS subsystem:

MOUNTD_OPTIONS [option_string]

The run time arguments for the rpc.mountd daemon used by /sbin/init.d/nfs.server. This variable will be obsolete in a future release.

MOUNTD_PORT [number]

The port number rpc.mountd should use for listening for incoming requests.

MOUNTD_TRACE [number]

Enables rpc.mountd tracing. This is equivalent to the -t command-line option. A value of 1 enables error tracing and a value greater than 1 increases the verbosity of the output.

NFS_CLIENT [0 | 1]

Used to enable or disable the NFS client service by /sbin/init.d/nfs.client. Can either be 0 to disable or 1 to enable the service. This variable will be obsolete in a future release.

NFS_CLIENT_VERSMAX [number]

The NFS client only uses NFS versions in the range specified by the NFS_CLIENT_VERSMAX and NFS_CLIENT_VERSMIN variables. Valid values are 2, 3, and 4. The default value for NFS_CLIENT_VERSMAX is 3. You can override this range on a per-mount bases by using the -o vers= option to mount_nfs.

NFS_CLIENT_VERSMIN [number]

The NFS client only uses NFS versions in the range specified by the NFS_CLIENT_VERSMAX and NFS_CLIENT_VERSMIN variables. Valid values are 2, 3, and 4. The default values for NFS_CLIENT_VERSMIN is 2. You can override this range on a per-mount bases by using the -o vers= option to mount_nfs.

NFS_SERVER [0 | 1]

Used to enable or disable the NFS server service by /sbin/init.d/nfs.server. Can either be 0 to disable or 1 to enable the service. This variable will be obsolete in a future release.

NFS_SERVER_DELEGATION [on | off]

The NFS server by default does not provide delegations to clients. Delegations can be turned on for all exported file systems by setting this variable to be on. This variable only applies to NFS Version 4. If local processes can access files in exported directories, NFS_SERVER_DELEGATION should not be turned on. The default is off.

NFS_SERVER_VERSMAX [number]

The NFS server only uses NFS versions in the range specified by NFS_SERVER_VERSMAX and NFS_SERVER_VERSMIN. Valid values are 2, 3, and 4. The default value is 3.

NFS_SERVER_VERSMIN [number]

The NFS server only uses NFS versions in the range specified by NFS_SERVER_VERSMAX and NFS_SERVER_VERSMIN. Valid values are 2, 3, and 4. The default value is 2.

NFSD_DEVICE [device_name]

Start nfsd on the transport specified by the given device only. Equivalent to the -t option in nfsd. Mutually exclusive of NFSD_PROTOCOL. Either NFSD_DEVICE or NFSD_PROTOCOL must be commented out.

NFSD_LISTEN_BACKLOG [number]

Set the connection queue length for NFS over a connection-oriented transport. The default value is 32, meaning 32 entries in the queue. Equivalent to the -l option in nfsd.

NFSD_MAX_CONNECTIONS [number]

Sets the maximum number of concurrent connection-oriented connections. This variable is read every time nfsd is run.

NFSD_PROTOCOL [string]

Start nfsd over the specified protocol only. Equivalent to the -p option in nfsd. ALL is equivalent to the -a option on the nfsd command line. Mutually exclusive of NFSD_DEVICE. Either NFSD_DEVICE or NFSD_PROTOCOL must be commented out. For the UDP protocol, only version 2 and version 3 NFS service is established. NFS Version 4 is not supported for the UDP protocol.

NFSD_SERVER [number]

The maximum number of concurrent NFS requests. Equivalent to last numeric argument on the nfsd command line. The default is 16.

NFSMAPID_DOMAIN [domain_string]

By default, the nfsmapid uses the DNS domain of the system. This setting overrides the default. This domain is used for identifying user and group attribute strings in the NFS Version 4 protocol. Clients and servers must match with this domain for operations to proceed normally. This variable only applies to NFS Version 4.

PCNFS_SERVER [0 | 1]

Used to enable or disable the pcnfsd daemon by /sbin/init.d/nfs.server. This variable will be obsolete in a future release.

START_MOUNTD [0 | 1]

Used to enable or disable the rpc.mountd daemon by /sbin/init.d/nfs.server. This variable will be obsolete in a future release.

The setoncenv command recognizes the following kernel tunable variable names for the NFS subsystem (a complete description of all NFS kernel tunable variables can be found in the NFS Services Administrator's Guide):

nfs2_async_clusters

Controls the mix of asynchronous requests for NFS version 2 clients.

nfs2_bsize

Controls the logical block size used by NFS version 2 clients.

nfs2_cots_timeo

Controls the default RPC timeout for NFS version 2 mounted file systems using a connection-oriented transport.

nfs2_do_symlink_cache

Used to enable or disable the symbolic link cache for NFS version 2 mounted file systems.

nfs2_dynamic

Used to enable or disable dynamic retransmission for NFS version 2 mounted file systems.

nfs2_lookup_neg_cache

Used to enable or disable the negative name cache used for NFS version 2 mounted file systems.

nfs2_max_threads

Controls the number of kernel threads that perform asynchronous I/O for NFS version 2 mount points.

nfs2_nra

Controls the number of read-ahead operations that are queued by the NFS version 2 client when sequentially accessing a file.

nfs2_shrinkreaddir

Limit the size of a READDIR request to be no greater than 1024 bytes of directory information.

nfs3_async_clusters

Controls the mix of asynchronous requests for NFS version 3 clients.

nfs3_bsize

Controls the logical block size used by NFS version 3 clients.

nfs3_cots_timeo

Controls the default RPC timeout for NFS version 3 mounted file systems using a connection-oriented transport.

nfs3_do_readdirplus

Control the ability to turn off the NFS version 3 readdirplus functionality on the NFS server.

nfs3_do_symlink_cache

Used to enable or disable the symbolic link cache for NFS version 3 mounted file systems.

nfs3_dynamic

Used to enable or disable dynamic retransmission for NFS version 3 mounted file systems.

nfs3_jukebox_delay

Controls the length of time the NFS version 3 client waits before re-transmitting a request after receiving the error NFS3ERR_JUKEBOX.

nfs3_lookup_neg_cache

Used to enable or disable the negative name cache used for NFS version 3 mounted file systems.

nfs3_max_threads

Controls the number of kernel threads that perform asynchronous I/O for NFS version 3 mount points.

nfs3_max_transfer_size

Controls the size of the data portion of an NFS version 3 READ, WRITE, READDIR, or READDIRPLUS request.

nfs3_max_transfer_size_clts

Controls the size of the data portion of an NFS version 3 READ, WRITE, READDIR, or READDIRPLUS request over UDP.

nfs3_max_transfer_size_cots

Controls the size of the data portion of an NFS version 3 READ, WRITE, READDIR, or READDIRPLUS request over TCP.

nfs3_nra

Controls the number of read-ahead operations that are queued by the NFS version 3 client when sequentially accessing a file.

nfs3_pathconf_disable_cache

Used to enable or disable the caching of pathconf information for NFS version 3 mounted file systems.

nfs4_async_clusters

Controls the mix of asynchronous requests for NFS version 4 clients.

nfs4_bsize

Controls the logical block size used by NFS version 4 clients.

nfs4_cots_timeo

Controls the default RPC timeout for NFS version 4 mounted file systems using a connection-oriented transport.

nfs4_do_symlink_cache

Used to enable or disable the symbolic link cache for NFS version 4 mounted file systems.

nfs4_lookup_neg_cache

Used to enable or disable the negative name cache used for NFS version 4 mounted file systems.

nfs4_max_threads

Controls the number of kernel threads that perform asynchronous I/O for NFS version 4 mount points.

nfs4_max_transfer_size

Controls the size of the data portion of an NFS version 4 READ, WRITE, READDIR, or READDIRPLUS request.

nfs4_max_transfer_size_cots

Controls the size of the data portion of an NFS version 4 READ, WRITE, READDIR, or READDIRPLUS request over TCP.

nfs4_nacache

Tunes the number of hash queues that access the file access cache on the NFS version 4 client.

nfs4_nra

Controls the number of read-ahead operations that are queued by the NFS version 4 client when sequentially accessing a file.

nfs4_nrnode

Controls the size of the NFS version 4 rnode cache on the NFS client.

nfs4_pathconf_disable_cache

Used to enable or disable the caching of pathconf information for NFS version 4 mounted file systems.

nfs_async_timeout

Controls the duration of time that the client's asynchronous I/O threads sleep with nothing to do before exiting.

nfs_disable_rddir_cache

Used to enable or disable the NFS directory caches.

nfs_exi_cache_time

Control the duration of time entries are held in the NFS authentication cache.

nfs_nacache

Tunes the number of hash queues that access the file access cache on the NFS version 2 and version 3 client.

nfs_nrnode

Controls the size of the rnode cache on the NFS version 2 and version 3 client.

nfs_portmon

Used to enable or disable the check to verify that the source port is a reserved port.

nfs_write_error_interval

Controls the duration between logging ENOSPC and EDQUOT errors.

nfs_write_error_to_cons_only

Used to enable or disable logging messages to both the system console and syslog.

The setoncenv command recognizes the following configuration variable names for the NFS logging subsystem:

CYCLE_FREQUENCY [number]

Specifies how often, in hours, the log files are cycled. This variable is used to insure that the log files do not get too large.

IDLE_TIME [number]

Specifies the amount of time, in seconds, the daemon, nfslogd should sleep while waiting for more information to be placed in the buffer file. This variable also determines how often the configuration file will be re-read.

MAX_LOGS_PRESERVE [number]

The nfslogd daemon periodically cycles its logs. This variable specifies the maximum number of log files to save. When MAX_LOGS_PRESERVE is reached, the oldest files will be overwritten as new log files are created. These files will be saved with a numbered extension, beginning with filename.0. The oldest file will have the highest numbered extension up to the value configured for MAX_LOGS_PRESERVE.

MIN_PROCESS_SIZE [number]

Specifies the minimum size, in bytes, that the buffer file must reach before processing the work information and writing to the log file.

START_NFSLOGD [0 | 1]

Used to enable or disable the nfslogd daemon by /sbin/init.d/nfs.server. This variable will be obsolete in a future release.

UMASK [mode]

Sets the file mode for the log files, work buffer files and file handle mapping database.

The setoncenv command recognizes the following configuration variable names for the NIS subsystem:

MAX_NISCHECKS [number]

The maximum number of times the NIS client should attempt to contact an NIS server before failing. This variable is used during system startup.

NIS_CLIENT [0 | 1]

Used to enable or disable the NIS client during system startup. Can either be 0 to disable or 1 to enable the service.

NIS_DOMAIN [domain_string]

Used to set the domain name by /sbin/init.d/nis.server and /sbin/init.d/nis.client.

NIS_MASTER_SERVER [0 | 1]

Used to enable or disable the NIS Master Server by /sbin/init.d/nis.server. Can either be 0 to disable or 1 to enable the service.

NIS_SLAVE_SERVER [0 | 1]

Used to enable or disable the NIS Slave Server by /sbin/init.d/nis.server. Can either be 0 to disable or 1 to enable the service.

SHADOW_MODE [0 | 1]

Enables and disables support for shadow passwords in NIS. Can either be 0 to disable or 1 to enable shadow password support.

YPBIND_OPTIONS [option_string]

The run time arguments for the ypbind daemon used by /sbin/init.d/nis.client.

YPPASSWDD_OPTIONS [option_string]

The run time arguments for the rpc.yppasswdd daemon used by /sbin/init.d/nis.server.

YPSERV_OPTIONS [option_string]

The run time arguments for the ypserv daemon used by /sbin/init.d/nis.server.

YPSET_ADDR [string]

This sets the IP address of an NIS server that the client should bind to. This value is used by /sbin/init.d/nis.client.

YPUPDATED_OPTIONS [option_string]

The run time arguments for the rpc.ypupdated daemon used by /sbin/init.d/nis.server.

YPXFRD_OPTIONS [option_string]

The run time arguments for the ypxfrd daemon used by /sbin/init.d/nis.server.

The setoncenv command recognizes the following configuration variable names for the rpcbind subsystem:

NFS_CORE [0 | 1]

Used to enable or disable the rpcbind service by /sbin/init.d/nfs.core. Can either be 0 to disable or 1 to enable the service. This variable will be obsolete in a future release.

RPCBIND_OPTIONS

The run time arguments for the rpcbind daemon used by /sbin/init.d/nfs.core. This variable will be obsolete in a future release.

COMMAND_START_DAEMON [0 | 1]

Used to enable or disable the functionality that allows the NFS commands to start subsystem daemons required for the NFS subsystem to work properly. If this variable is enabled, the NFS subsystem start and stop scripts will no longer start the NFS daemons. The daemons will only be started if one of NFS subsystem commands is run. For example, if a file system is shared using the share command, the NFS daemons, rpc.statd, rpc.lockd, nfsmapid, rpc.mountd, and nfsd will be started if not already running. If an NFS file system is mounted, the NFS mount command will start the NFS daemons, rpc.statd, rpc.lockd, and if it is an NFSv4 mount, nfsmapid, and nfs4cbd will be started if not already running.

AUTHOR

setoncenv was developed by the Hewlett-Packard Company.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.