Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > T

term_c(4)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

term_c: term.h, TERM — terminal capabilities

DESCRIPTION

The header <term.h> contains definitions for each of the following symbolic constants and capability names in the following tables.

In the following table, a Variable is the name by which a C programmer accesses a capability (at the terminfo level). A Capname is the short name for a capability specified in the terminfo source file. It is used by a person updating the source file and by the tput command.

Booleans

Cap-Termcap
VariablenameCodeDescription
auto_left_marginbwbwcub1 wraps from column 0 to last column
auto_right_marginamamTerminal has automatic margins
back_color_erasebceutScreen erased with background color
buttonsbtnsBTNumber of buttons on the mouse
can_changecccccTerminal can re-define existing color
ceol_standout_glitchxhpxsStandout not erased by overwriting (hp)
col_addr_glitchxhpaYAOnly positive motion for hpa/mhpa caps
cpi_changes_rescpixYFChanging character pitch changes resolution
create_windowcwinCWDefine win #1 to go from #2,#3 to #4,#5
cr_cancels_micro_modecrxmYBUsing cr turns off micro mode
dest_tabs_magic_smsoxtxtDestructive tabs, magic smso char (t1061)
dial_phonedialDIDial phone number #1
display_clockdclkDKDisplay time-of-day clock
eat_newline_glitchxenlxnNewline ignored after 80 columns (Concept)
erase_overstrikeeoeoCan erase overstrikes with a blank
fixed_pausepausePAPause for 2-3 seconds
flash_hookhookfhFlash the switch hook
generic_typegngnGeneric line type (for example, dialup, switch)
get_mousegetmGmCurses should get button events
goto_windowwingoWGGot to window #1
hanguphupHUHang-up phone
hard_copyhchcHardcopy terminal
hard_cursorchtsHCCursor is hard to see
has_meta_keykmkmHas a meta key (shift, sets parity bit)
has_print_wheeldaisyYCPrinter needs operator to change character set
has_status_linehshsHas extra "status line"
hue_lightness_saturationhlshlTerminal uses only HLS color notation (Tektronix)
insert_null_glitchininInsert mode distinguishes nulls
lpi_changes_reslpixYGChanging line pitch changes resolution
memory_abovedadaDisplay may be retained above the screen
memory_belowdbdbDisplay may be retained below the screen
move_insert_modemirmiSafe to move while in insert mode
move_standout_modemsgrmsSafe to move in standout modes
needs_xon_xoffnxonnxPadding won't work, xon/xoff required
no_esc_ctlcxsbxbBeehive (f1=escape, f2=ctrl C)
no_pad_charnpcNPPad character doesn't exist
non_dest_scroll_regionndscrNDScrolling region is nondestructive
non_rev_rmcupnrrmcNRsmcup does not reverse rmcup
over_strikeososTerminal overstrikes on hard-copy terminal
print_ratecpsYmPrint rate in characters per second
prtr_silentmc5i5iPrinter won't echo on screen
row_addr_glitchxvpaYDOnly positive motion for vpa/mvpa caps
semi_auto_right_marginsamYEPrinting in last column causes cr
set_pglen_inchslengthYISet page length to #1 hundredth of an inch (use tparm)
status_line_esc_okeslokesEscape can be used on the status line
tilde_glitchhzhzHazeltine; can't print tilde (~)
transparent_underlineululUnderline character overstrikes
xon_xoffxonxoTerminal uses xon/xoff handshaking

Numbers

Cap-Termcap
VariablenameCodeDescription
bit_image_entwiningbitwinYoNumber of passes for each bit-map row
bit_image_typebitypeYpType of bit image device
buffer_capacitybufszYaNumber of bytes buffered before printing
columnscolscoNumber of columns in a line
dot_horz_spacingspinhYcSpacing of dots horizontally in dots per inch
dot_vert_spacingspinvYbSpacing of pins vertically in pins per inch
init_tabsititTabs initially every # spaces
label_heightlhlhNumber of rows in each label
label_widthlwlwNumber of columns in each label
lineslinesliNumber of lines on a screen or a page
lines_of_memorylmlmLines of memory if > lines; 0 means varies
max_attributesmamaMaximum combined video attributes terminal can display
magic_cookie_glitchxmcsgNumber of blank chars left by smso or rmso
max_colorscolorsCoMaximum number of colors on the screen
max_micro_addressmaddrYdMaximum value in micro_..._address
max_micro_jumpmjumpYeMaximum value in parm_..._micro
max_pairspairspaMaximum number of color-pairs on the screen
maximum_windowsWnumMWMaximum number of definable windows
micro_char_sizemcsYgCharacter step size when in micro mode
micro_line_sizemlsYfLine step size when in micro mode
no_color_videoncvNCVideo attributes that can't be used with colors
num_labelsnlabNlNumber of labels on screen (start at 1)
number_of_pinsnpinsYhNumber of pins in print-head
output_res_charorcYiHorizontal resolution in units per character
output_res_lineorlYjVertical resolution in units per line
output_res_horz_inchorhiYkHorizontal resolution in units per inch
output_res_vert_inchorviYlVertical resolution in units per inch
padding_baud_ratepbpbLowest baud rate where padding needed
virtual_terminalvtvtVirtual terminal number
wide_char_sizewidcsYnCharacter step size when in double wide mode
width_status_linewslwsNumber of columns in status line

Strings

Cap-Termcap
VariablenameCodeDescription
acs_charsacscacGraphic charset pairs aAbBcC
alt_scancode_escscesaS8Alternate escape for scancode emulation (default is for vt100)
back_tabcbtbtBack tab
bellbelblAudible signal (bell)
bit_image_carriage_returnbicrYvMove to beginning of same row (use tparm)
bit_image_newlinebinelZzMove to next row of the bit image (use tparm)
bit_image_repeatbirepXyRepeat bit-image cell #1 #2 times (use tparm)
carriage_returncrcrCarriage return
change_char_pitchcpiZAChange number of characters per inch
change_line_pitchlpiZBChange number of lines per inch
change_res_horzchrZCChange horizontal resolution
change_res_vertcvrZDChange vertical resolution
change_scroll_regioncsrcsChange to lines #1 through #2 (vt100)
char_paddingrmprPLike ip but when in replace mode
char_set_namescsnmZyList of character set names
clear_all_tabstbcctClear all tab stops
clear_marginsmgcMCClear all margins (top, bottom, and sides)
clear_screenclearclClear screen and home cursor
clr_bolel1cbClear to beginning of line, inclusive
clr_eolelceClear to end of line
clr_eosedcdClear to end of display
code_set_initcsinciInit sequence for multiple codesets
color_namescolornmYwGive name for color #1
column_addresshpachHorizontal position absolute
command_charactercmdchCCTerminal settable cmd character in prototype
cursor_addresscupcmMove to row #1 col #2
cursor_downcud1doDown one line
cursor_homehomehoHome cursor (if no cup)
cursor_invisiblecivisviMake cursor invisible
cursor_leftcub1leMove left one space.
cursor_mem_addressmrcupCMMemory relative cursor addressing
cursor_normalcnormveMake cursor appear normal (undo vs/vi)
cursor_rightcuf1ndNon-destructive space (cursor or carriage right)
cursor_to_llllllLast line, first column (if no cup)
cursor_upcuu1upUpline (cursor up)
cursor_visiblecvvisvsMake cursor very visible
define_bit_image_regiondefbiYxDefine rectangular bit-image region (use tparm)
define_chardefcZEDefine a character in a character set
delete_characterdch1dcDelete character
delete_linedl1dlDelete line
device_typedevtdvIndicate language/codeset support
dis_status_linedsldsDisable status line
display_pc_chardispcS1Display PC character
down_half_linehdhdHalf-line down (forward 1/2 linefeed)
ena_acsenacseAEnable alternate character set
end_bit_image_regionendbiYyEnd a bit-image region (use tparm)
enter_alt_charset_modesmacsasStart alternate character set
enter_am_modesmamSATurn on automatic margins
enter_blink_modeblinkmbTurn on blinking
enter_bold_modeboldmdTurn on bold (extra bright) mode
enter_ca_modesmcuptiString to begin programs that use cup
enter_delete_modesmdcdmDelete mode (enter)
enter_dim_modedimmhTurn on half-bright mode
enter_doublewide_modeswidmZFEnable double wide printing
enter_draft_qualitysdrfqZGSet draft quality print
enter_horizontal_hl_modeehhlmn/aturn on horizontal highlight mode
enter_insert_modesmirimInsert mode (enter)
enter_italics_modesitmZHEnable italics
enter_left_hl_modeelhlmn/aTurn on left highlight mode
enter_leftward_modeslmZIEnable leftward carriage motion
enter_low_hl_modeelohlmn/aturn on low highlight mode
enter_micro_modesmicmZJEnable micro motion capabilities
enter_near_letter_qualitysnlqZKSet near-letter quality print
enter_normal_qualitysnrmqZLSet normal quality print
enter_pc_charset_modesmpchS2Enter PC character display mode
enter_protected_modeprotmpTurn on protected mode
enter_reverse_moderevmrTurn on reverse video mode
enter_right_hl_modeerhlmn/aturn on right highlight mode
enter_scancode_modesmscS4Enter PC scancode mode
enter_secure_modeinvismkTurn on blank mode (characters invisible)
enter_shadow_modesshmZMEnable shadow printing
enter_standout_modesmsosoBegin standout mode
enter_subscript_modessubmZNEnable subscript printing
enter_superscript_modessupmZOEnable superscript printing
enter_top_hl_modeethlmn/aTurn on top highlight mode
enter_underline_modesmulusStart underscore mode
enter_upward_modesumZPEnable upward carriage motion
enter_vertical_hl_modeevhlmn/aturn on vertical highlight mode
enter_xon_modesmxonSXTurn on xon/xoff handshaking
erase_charsechecErase #1 characters
exit_alt_charset_modermacsaeEnd alternate character set
exit_am_modermamRATurn off automatic margins
exit_attribute_modesgr0meTurn off all attributes
exit_ca_modermcupteString to end programs that use cup
exit_delete_modermdcedEnd delete mode
exit_doublewide_moderwidmZQDisable double wide printing
exit_insert_modermireiEnd insert mode
exit_italics_moderitmZRDisable italics
exit_leftward_moderlmZSEnable rightward (normal) carriage motion
exit_micro_modermicmZTDisable micro motion capabilities
exit_pc_charset_modermpchS3Disable PC character display mode
exit_scancode_modermscS5Disable PC scancode mode
exit_shadow_modershmZUDisable shadow printing
exit_standout_modermsoseEnd standout mode
exit_subscript_modersubmZVDisable subscript printing
exit_superscript_modersupmZWDisable superscript printing
exit_underline_modermulueEnd underscore mode
exit_upward_moderumZXEnable downward (normal) carriage motion
exit_xon_modermxonRXTurn off xon/xoff handshaking
flash_screenflashvbVisible bell (may not move cursor)
form_feedffffHardcopy terminal page eject
from_status_linefslfsReturn from status line
init_1stringis1i1Terminal or printer initialization string
init_2stringis2isTerminal or printer initialization string
init_3stringis3i3Terminal or printer initialization string
init_fileififName of initialization file
init_progiprogiPPath name of program for initialization
initialize_colorinitcICInitialize the definition of color
initialize_pairinitpIpInitialize color-pair
insert_characterich1icInsert character
insert_lineil1alAdd new blank line
insert_paddingipipInsert pad after character inserted

The key_ strings are sent by specific keys. The key_ descriptions include the macro, defined in <curses.h>, for the code returned by the CURSES function getch() when the key is pressed (see curs_getch(3X)).

Cap-Termcap
VariablenameCodeDescription
key_a1ka1K1upper left of keypad
key_a3ka3K3upper right of keypad
key_b2kb2K2center of keypad
key_backspacekbskbsent by backspace key
key_begkbeg@1sent by beg(inning) key
key_btabkcbtkBsent by back-tab key
key_c1kc1K4lower left of keypad
key_c3kc3K5lower right of keypad
key_cancelkcan@2sent by cancel key
key_catabktbckasent by clear-all-tabs key
key_clearkclrkCsent by clear-screen or erase key
key_closekclo@3sent by close key
key_commandkcmd@4sent by cmd (command) key
key_copykcpy@5sent by copy key
key_createkcrt@6sent by create key
key_ctabkctabktsent by clear-tab key
key_dckdch1kDsent by delete-character key
key_dlkdl1kLsent by delete-line key
key_downkcud1kdsent by terminal down-arrow key
key_eickrmirkMsent by rmir or smir in insert mode
key_endkend@7sent by end key
key_enterkent@8sent by enter/send key
key_eolkelkEsent by clear-to-end-of-line key
key_eoskedkSsent by clear-to-end-of-screen key
key_exitkext@9sent by exit key
key_f0kf0k0sent by function key f0
key_f1kf1k1sent by function key f1
key_f2kf2k2sent by function key f2
key_f3kf3k3sent by function key f3
key_f4kf4k4sent by function key f4
key_f5kf5k5sent by function key f5
key_f6kf6k6sent by function key f6
key_f7kf7k7sent by function key f7
key_f8kf8k8sent by function key f8
key_f9kf9k9sent by function key f9
key_f10kf10k;sent by function key f10
key_f11kf11F1sent by function key f11
key_f12kf12F2sent by function key f12
key_f13kf13F3sent by function key f13
key_f14kf14F4sent by function key f14
key_f15kf15F5sent by function key f15
key_f16kf16F6sent by function key f16
key_f17kf17F7sent by function key f17
key_f18kf18F8sent by function key f18
key_f19kf19F9sent by function key f19
key_f20kf20FAsent by function key f20
key_f21kf21FBsent by function key f21
key_f22kf22FCsent by function key f22
key_f23kf23FDsent by function key f23
key_f24kf24FEsent by function key f24
key_f25kf25FFsent by function key f25
key_f26kf26FGsent by function key f26
key_f27kf27FHsent by function key f27
key_f28kf28FIsent by function key f28
key_f29kf29FJsent by function key f29
key_f30kf30FKsent by function key f30
key_f31kf31FLsent by function key f31
key_f32kf32FMsent by function key f32
key_f33kf33FNsent by function key f33
key_f34kf34FOsent by function key f34
key_f35kf35FPsent by function key f35
key_f36kf36FQsent by function key f36
key_f37kf37FRsent by function key f37
key_f38kf38FSsent by function key f38
key_f39kf39FTsent by function key f39
key_f40kf40FUsent by function key f40
key_f41kf41FVsent by function key f41
key_f42kf42FWsent by function key f42
key_f43kf43FXsent by function key f43
key_f44kf44FYsent by function key f44
key_f45kf45FZsent by function key f45
key_f46kf46Fasent by function key f46
key_f47kf47Fbsent by function key f47
key_f48kf48Fcsent by function key f48
key_f49kf49Fdsent by function key f49
key_f50kf50Fesent by function key f50
key_f51kf51Ffsent by function key f51
key_f52kf52Fgsent by function key f52
key_f53kf53Fhsent by function key f53
key_f54kf54Fisent by function key f54
key_f55kf55Fjsent by function key f55
key_f56kf56Fksent by function key f56
key_f57kf57Flsent by function key f57
key_f58kf58Fmsent by function key f58
key_f59kf59Fnsent by function key f59
key_f60kf60Fosent by function key f60
key_f61kf61Fpsent by function key f61
key_f62kf62Fqsent by function key f62
key_f63kf63Frsent by function key f63
key_findkfnd@0sent by find key
key_helpkhlp%1sent by help key
key_homekhomekhsent by home key
key_ickich1kIsent by ins-char/enter ins-mode key
key_ilkil1kAsent by insert-line key
key_leftkcub1klsent by terminal left-arrow key
key_llkllkHsent by home-down key
key_markkmrk%2sent by mark key
key_messagekmsg%3sent by message key
key_mousekmousKm0631, Mouse event has occurred
key_movekmov%4sent by move key
key_nextknxt%5sent by next-object key
key_npageknpkNsent by next-page key
key_openkopn%6sent by open key
key_optionskopt%7sent by options key
key_ppagekppkPsent by previous-page key
key_previouskprv%8sent by previous-object key
key_printkprt%9sent by print or copy key
key_redokrdo%0sent by redo key
key_referencekref&1sent by ref(erence) key
key_refreshkrfr&2sent by refresh key
key_replacekrpl&3sent by replace key
key_restartkrst&4sent by restart key
key_resumekres&5sent by resume key
key_rightkcuf1krsent by terminal right-arrow key
key_saveksav&6sent by save key
key_sbegkBEG&9sent by shifted beginning key
key_scancelkCAN&0sent by shifted cancel key
key_scommandkCMD*1sent by shifted command key
key_scopykCPY*2sent by shifted copy key
key_screatekCRT*3sent by shifted create key
key_sdckDC*4sent by shifted delete-char key
key_sdlkDL*5sent by shifted delete-line key
key_selectkslt*6sent by select key
key_sendkEND*7sent by shifted end key
key_seolkEOL*8sent by shifted clear-line key
key_sexitkEXT*9sent by shifted exit key
key_sfkindkFsent by scroll-forward/down key
key_sfindkFND*0sent by shifted find key
key_shelpkHLP#1sent by shifted help key
key_shomekHOM#2sent by shifted home key
key_sickIC#3sent by shifted input key
key_sleftkLFT#4sent by shifted left-arrow key
key_smessagekMSG%asent by shifted message key
key_smovekMOV%bsent by shifted move key
key_snextkNXT%csent by shifted next key
key_soptionskOPT%dsent by shifted options key
key_spreviouskPRV%esent by shifted prev key
key_sprintkPRT%fsent by shifted print key
key_srkrikRsent by scroll-backward/up key
key_sredokRDO%gsent by shifted redo key
key_sreplacekRPL%hsent by shifted replace key
key_srightkRIT%isent by shifted right-arrow key
key_srsumekRES%jsent by shifted resume key
key_ssavekSAV!1sent by shifted save key
key_ssuspendkSPD!2sent by shifted suspend key
key_stabkhtskTsent by set-tab key
key_sundokUND!3sent by shifted undo key
key_suspendkspd&7sent by suspend key
key_undokund&8sent by undo key
key_upkcuu1kusent by terminal up-arrow key
keypad_localrmkxkeOut of "keypad-transmit" mode
keypad_xmitsmkxksPut terminal in "keypad-transmit" mode
lab_f0lf0l0Labels on function key f0 if not f0
lab_f1lf1l1Labels on function key f1 if not f1
lab_f2lf2l2Labels on function key f2 if not f2
lab_f3lf3l3Labels on function key f3 if not f3
lab_f4lf4l4Labels on function key f4 if not f4
lab_f5lf5l5Labels on function key f5 if not f5
lab_f6lf6l6Labels on function key f6 if not f6
lab_f7lf7l7Labels on function key f7 if not f7
lab_f8lf8l8Labels on function key f8 if not f8
lab_f9lf9l9Labels on function key f9 if not f9
lab_f10lf10laLabels on function key f10 if not f10
label_formatflnLfLabel format
label_offrmlnLFTurn off soft labels
label_onsmlnLOTurn on soft labels
meta_offrmmmoTurn off "meta mode"
meta_onsmmmmTurn on "meta mode" (8th bit)
micro_column_addressmhpaZYLike column_address for micro adjustment
micro_downmcud1ZZLike cursor_down for micro adjustment
micro_leftmcub1ZaLike cursor_left for micro adjustment
micro_rightmcuf1ZbLike cursor_right for micro adjustment
micro_row_addressmvpaZcLike row_address for micro adjustment
micro_upmcuu1ZdLike cursor_up for micro adjustment
mouse_infominfoMiMouse status information
newlinenelnwNewline (behaves like cr followed by lf)
order_of_pinsporderZeMatches software bits to print-head pins
orig_colorsococSet all color(-pair)s to the original ones
orig_pairopopSet default color-pair to the original one
pad_charpadpcPad character (rather than null)
parm_dchdchDCDelete #1 chars
parm_delete_linedlDLDelete #1 lines
parm_down_cursorcudDOMove down #1 lines.
parm_down_micromcudZfLike parm_down_cursor for micro adjust.
parm_ichichICInsert #1 blank chars
parm_indexindnSFScroll forward #1 lines.
parm_insert_lineilALAdd #1 new blank lines
parm_left_cursorcubLEMove cursor left #1 spaces
parm_left_micromcubZgLike parm_left_cursor for micro adjust.
parm_right_cursorcufRIMove right #1 spaces.
parm_right_micromcufZhLike parm_right_cursor for micro adjust.
parm_rindexrinSRScroll backward #1 lines.
parm_up_cursorcuuUPMove cursor up #1 lines.
parm_up_micromcuuZiLike parm_up_cursor for micro adjust.
pc_term_optionspctrmS6PC terminal options
pkey_keypfkeypkProg funct key #1 to type string #2
pkey_localpflocplProg funct key #1 to execute string #2
pkey_plabpfxlxlProg key #1 to xmit string #2 and show string #3
pkey_xmitpfxpxProg funct key #1 to xmit string #2
plab_normplnpnProg label #1 to show string #2
print_screenmc0psPrint contents of the screen
prtr_nonmc5ppOTurn on the printer for #1 bytes
prtr_offmc4pfTurn off the printer
prtr_onmc5poTurn on the printer
pulsepulsePUSelect pulse dialing
quick_dialqdialQDDial phone number #1, without progress detection
remove_clockrmclkRCRemove time-of-day clock
repeat_charreprpRepeat char #1 #2 times
req_for_inputrfiRFSend next input char (for ptys)
req_mouse_posreqmpRQRequest mouse position report
reset_1stringrs1r1Reset terminal completely to sane modes
reset_2stringrs2r2Reset terminal completely to sane modes
reset_3stringrs3r3Reset terminal completely to sane modes
reset_filerfrfName of file containing reset string
restore_cursorrcrcRestore cursor to position of last sc
row_addressvpacvVertical position absolute
save_cursorscscSave cursor position
scancode_escapescescS7Escape for scancode emulation
scroll_forwardindsfScroll text up
scroll_reverserisrScroll text down
select_char_setscsZjSelect character set
set0_des_seqs0dss0Shift into codeset 0 (EUC set 0, ASCII)
set1_des_seqs1dss1Shift into codeset 1
set2_des_seqs2dss2Shift into codeset 2
set3_des_seqs3dss3Shift into codeset 3
set_a_backgroundsetabABSet background color using ANSI escape
set_a_foregroundsetafAFSet foreground color using ANSI escape
set_attributessgrsaDefine the video attributes #1-#9
set_backgroundsetbSbSet current background color
set_bottom_marginsmgbZkSet bottom margin at current line
set_bottom_margin_parmsmgbpZlSet bottom margin at #1 or #2 lines from bottom
set_clocksclkSCSet time-of-day clock
set_color_bandsetcolorYzChange to ribbon color #1
set_color_pairscpspSet current color-pair
set_foregroundsetfSfSet current foreground color1
set_left_marginsmglMLSet left margin at current line
set_left_margin_parmsmglpZmSet left (right) margin at column #1 (#2)
set_lr_marginsmglrMLSets both left and right margins
set_page_lengthslinesYZSet page length to #1 lines (use tparm)
set_right_marginsmgrMRSet right margin at current column
set_right_margin_parmsmgrpZnSet right margin at column #1
set_tabhtsstSet a tab in all rows, current column
set_tb_marginsmgtbMTSets both top and bottom margins
set_top_marginsmgtZoSet top margin at current line
set_top_margin_parmsmgtpZpSet top (bottom) margin at line #1 (#2)
set_windowwindwiCurrent window is lines #1-#2 cols #3-#4
start_bit_imagesbimZqStart printing bit image graphics
start_char_set_defscsdZrStart definition of a character set
stop_bit_imagerbimZsEnd printing bit image graphics
stop_char_set_defrcsdZtEnd definition of a character set
subscript_characterssubcsZuList of "subscript-able" characters
superscript_characterssupcsZvList of "superscript-able" characters
tabhttaTab to next 8-space hardware tab stop
these_cause_crdocrZwPrinting any of these chars causes cr
to_status_linetsltsGo to status line, col #1
tonetoneTOSelect touch tone dialing
user0u0U0User string 0
user1u1U1User string 1
user2u2U2User string 2
user3U3u3User string 3
user4u4u4User string 4
user5u5u5User string 5
user6u6u6User string 6
user7u7u7User string 7
user8u8u8User string 8
user9u9u9User string 9
underline_charucucUnderscore one char and move past it
up_half_linehuhuHalf-line up (reverse 1/2 linefeed)
wait_tonewaitWAWait for dial tone
xoff_characterxoffcXFX-off character
xon_characterxoncXNX-on character
zero_motionzeromZxNo motion for the subsequent character

The following are declared as functions and may be defined as macros:

int tgetent(char *bp, char *name); int tgetflag(char id[2]); int tgetnum(char id[2]); char *tgetstr(char id[2], char **area); char *tgoto(char *cap, int col, int row); int tputs(char *str, int affcnt, int (*putc)(void));

SEE ALSO

printf(1).

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.